USERTrust RSA Certification Authority expired
Incident Report for SDKMAN!
Resolved
This incident has been resolved.
Posted May 31, 2020 - 06:19 UTC
Monitoring
New reissued certificates have been installed and we will continue to monitor that all service has been restored.
Posted May 30, 2020 - 22:27 UTC
Update
A new certificate has been issued and has now been installed across all our services and website. We will now proceed to test that all is operational again.
Posted May 30, 2020 - 22:15 UTC
Investigating
We have investigated multiple reports of an expired certificate in our certificate chain and can confirm that this is the case.

The expired certificate is one issued by USERTrust RSA Certification Authority. Despite a successful renewal of the wildcard domain certificate on 22 April 2020, an additional certificate seems to have expired today, 30 May 2020.

This is causing issues when curl attempts to access our APIs over https. SDKMAN relies heavily on curl for all it's API interactions.

A temporary workaround is to allow insecure SSL access for curl, although this is not advised unless absolutely necessary. See our website for more details about the `sdkman_insecure_ssl=true` config setting: https://sdkman.io/usage#config

Further information about the expiration of this certificate can be found here: https://support.sectigo.com/articles/Knowledge/Sectigo-AddTrust-External-CA-Root-Expiring-May-30-2020
Posted May 30, 2020 - 21:25 UTC
This incident affected: SSL Certificates.